Database Change Management
Database Change Management
Home | Profile | Register | Active Topics | Active Polls | Members | Private Messages | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?




 All Forums
 Support
 DB Ghost Support Forum
 Static data tables in Packager Plus upgrades
 New Topic  New Poll New Poll
 Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Gary


12 Posts

Posted - 05/01/2012 :  06:17:32  Show Profile Send Gary a Private Message  Reply with Quote
I have configured a database and set a table to be included for static data in both create and update modes. The table gets populated correctly during creation, but it isn't synchronised during subsequent upgrades, which caused a fair bit of confusion with our client due to a resulting bug.

I've tested the packager locally and confirmed that the selected table is not synced with the data as expected. Can someone tell me why this might be the case and how I can resolve the problem?

Google AdSense

USA
Mountain View


jon.woolgar



105 Posts

Posted - 05/01/2012 :  09:28:56  Show Profile  Visit jon.woolgar's Homepage Send jon.woolgar a Private Message  Reply with Quote
Does the table have an PK? If not DBG cant do a proper compare and will if allowed by the options you set blast the source data over the target data.

Regards Jon W
(Innovartis)
Go to Top of Page

Gary



12 Posts

Posted - 05/01/2012 :  09:55:16  Show Profile Send Gary a Private Message  Reply with Quote
Yes, the table does have a PK and I'd be happy for PP to fully overwrite all its contents, but it doesn't appear to do anything at all. I ran Profiler during an upgrade and I saw no attempts to modify the data.
Go to Top of Page

jon.woolgar



105 Posts

Posted - 05/01/2012 :  12:11:39  Show Profile  Visit jon.woolgar's Homepage Send jon.woolgar a Private Message  Reply with Quote
This rings a bell. Which version are you running? I'll check the changes since your version.

Regards Jon W
(Innovartis)
Go to Top of Page

Gary



12 Posts

Posted - 05/01/2012 :  14:47:04  Show Profile Send Gary a Private Message  Reply with Quote
5.0.0.1363
Go to Top of Page

jon.woolgar



105 Posts

Posted - 05/01/2012 :  15:12:11  Show Profile  Visit jon.woolgar's Homepage Send jon.woolgar a Private Message  Reply with Quote
Here is a link to the latest code
You must be logged in to see this link.

Could you save the settings you used when making the package? There is a "Save DB Ghost Packager Project" link on the final screen or the wizard. You can email me the xml file jon.woolgar@innovartis.co.uk

Regards Jon W
(Innovartis)
Go to Top of Page

Gary



12 Posts

Posted - 05/02/2012 :  07:16:50  Show Profile Send Gary a Private Message  Reply with Quote
Thanks! I upgraded to the provided build, re-tested and it does now sync the data in the selected tables.

Unfortunately, it also appears to have introduced a bug/changed behaviour in how relative paths are handled for custom scripts. In the previous version of my XML file (which I'll email to you), I used relative paths, e.g. ".\Custom\AfterSync\Create_IIS_user.sql". With the later build you provided, the Packager throws an error, complaining that it can't find that file. If I change the path to an absolute one, then it works again.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  New Poll New Poll
 Reply to Topic
 Printer Friendly
Jump To:
Database Change Management © Copyright 2005 Innovartis Ltd. Go To Top Of Page
Snitz Forums 2000
RSS Feed 1 RSS Feed 2
Powered by ForumCo 2000-2008
TOS - AUP - URA - Privacy Policy
ForumCo Free Blogs and Galleries
Signup for a free forum or Go Banner Free